Helix Test Case Management Quick Start
Guide
This guide is provided to help you get started with test case management in Helix ALM and answer common
questions about working with test cases and test runs. Your use of Helix ALM may be different based upon
your organization’s testing process, but the same basic concepts apply.
Note: The information in this guide applies to the Helix ALM Client. Test case management is also
supported in Helix ALM Web. See the Helix ALM Web help for information.

How does our manual process translate to Helix ALM?
Helix ALM is ready to use out of the box, but can also be customized to fit your terminology, methodology, and
regulations. Before your organization begins to use Helix ALM, it is important to take the time to evaluate and
document each step in your testing process. Consider the following questions:
n

What actions need to be performed?

n

Who is responsible for performing each action?

n

What data needs to be tracked for each action?

n

What is required to move to the next step in the process?

n

What business or compliance rules do you need to enforce in the process?

Answering these questions can help you determine how to use Helix ALM to automate your process. The
Helix ALM administrator or another high-level user is generally responsible for customization.

Workflows
Helix ALM includes default test case and test run workflows. To move a test case or test run through the
workflow, it is assigned to users who perform the required work. The workflows can be customized to adapt to
your testing process or used as is.
The following diagram shows a high-level overview of the testing process supported by the default workflows.
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Test items

Test items
The test items used in your manual process are all represented in Helix ALM. In your process, you may have
created a checklist of items to test. When a new product version required testing, you printed the checklist
and wrote the test results on it. These items are all used in Helix ALM.
n

The checklist is a test suite. In Helix ALM, you use test case suite folders to group related test cases. You
can also group related test runs in test run suite folders.

n

Each line in the checklist is a test case.

n

The printed checklist is a test run set. In Helix ALM, you can add new test runs to test run sets, which can
help you report on each test initiative and determine the current status.

n

Each item in the printed checklist is a test run. In Helix ALM, test runs are generated from test cases at a
milestone in the testing process. Testers use test runs to perform a test and enter the results.

The following diagram shows the relationship between these components.
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How do I access test case management?

How do I access test case management?
Features for test case, issue, and requirements management are installed with Helix ALM. To access test
case management features:
n

You must have a valid test case management license to work with test cases and test runs, even if you
can already work with issues or requirements.

n

Make sure your Helix ALM administrator provided the Helix ALM Server connection information and your
username and password.

n

When logging in, expand Log in to on the Helix ALM Project Selection dialog box and select Test case
management.

n

If you cannot access test case management features, the administrator may need to enable test case
management for the project. Choose Tools > Administration > Project Options. In the General
category, select Allow users to access test cases and test runs, and click OK. Users must log in to the
project again.

What are test cases?
Test cases include all information about a test, including the description, scope, conditions, detailed steps,
expected results, scripts, and other test data. Each test case should focus on only one component or
requirement.
To work with test cases, choose View > Test Cases to open the Test Cases list window.
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What are test runs?

What are test runs?
Test runs are instances of a test case used to perform a test and document the results. Test runs are
generated from a test case, typically at a milestone in the testing cycle. All information is copied from a test
case to the related test runs.
A single test case can have one or more related test runs, which are performed against different builds or
configurations.
To work with test runs, choose View > Test Runs to open the Test Runs list window.

What are the differences between test cases and test runs?
Test cases generally do not change unless they include incorrect information or the tested application
changes. They remain open and are reused to test subsequent builds and releases. Test cases are not used
to perform tests and do not include results.
Test runs are only used once to perform a specific test during a testing cycle. Test runs include the test
results and are closed after the specific test is performed.

What information should a test case include?
A test case should include all the information a tester needs to successfully perform a test. It is important to
include complete information to avoid ambiguity during testing. All the test case information is copied to test
runs when they are generated.
Test cases generally include the following information:
n

Details—The estimated time to perform the test, a description of the scope of the test, any test
environment setup information or other requirements that must be in place before the test is performed,
and the expected outcome of the test. Your organization may also use custom fields to capture additional
information in the test case details.

n

Steps and expected results—The specific actions the tester needs to perform, in sequential order.
Expected results can be added to each step to describe the outcome of completing the step.
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How do I reuse steps across multiple test cases?

n

Supporting files—Any files that can help the tester perform the test can be attached to a test case. You
can attach automated scripts, source code files, or other files, such as requirements, test data, or
screenshots.

To create a test case, choose Create > Test Case or click Add on the Test Cases list window.

How do I reuse steps across multiple test cases?
You may have multiple test cases that include the same subset of steps. For example, several test cases
may include steps for logging in to an application. Instead of maintaining the steps separately in each test
case, you can create one test case that includes the login steps and share the steps in other test cases.
Using modular test cases and sharing steps can help you write test cases more quickly and reduce
maintenance effort when steps change.
When you insert shared steps in a test case, a hyperlink to the shared test case is added to the test case.
When test runs are generated, all steps from the shared test case and any attachments are included in the
test runs.
To share test case steps, create the original test case and then click Insert Shared Steps on the Steps tab
when creating other test cases you want to share the steps with.

How do I use a single test case to support multiple
configurations?
If the same test needs to be performed against different builds or configurations, you can use one test case to
cover all the required tests.
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How do I make sure that only valid test variants are used?

Helix ALM includes test variants, which represent the variable elements of an application that need to be
tested, such as multiple platforms, databases, or client types. When you generate test runs, you select the
test variant values to use. A test run is created for each unique combination of the selected variant values.
For example, if you test a web-based application in multiple browsers, you can create a Browser test variant
with Internet Explorer, Firefox, Safari, and other browsers as the variant values. When you generate test runs,
unique test runs are generated for each browser you select.
The Helix ALM administrator or another high-level user generally configures test variants. To create test
variants, choose Tools > Custom Fields and then select Test Variants as the Type.

How do I make sure that only valid test variants are used?
When you generate test runs, every test variant value is available. While this makes it easy to quickly
generate a large number of test cases, you could end up with dozens of test runs that do not apply to the test
case. Instead, you can add the variant values in test cases to always include or exclude them when test runs
are generated.
n

Included test variant values are always used to generate test runs. If you add included test variant values
to a test case, no other values will be used to generate test runs.

n

Excluded test variant values are never used to generate test runs. If you add excluded test variant values
to a test case, all values except the excluded values will be used to generate test runs.

To include or exclude test variant values in test cases, click the Variants tab in the Add Test Case or Edit
Test Case dialog box.

Note: If you add included test variant values and do not add excluded values, all test runs include all
variant values. Make sure you add excluded test variant values if the test case does not apply to a
specific variant value.

What information do test runs include?
When test runs are generated, all information from the related test case is copied to the test runs. Test runs
also include the test results entered by the user who performed the test.
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What information do test runs include?

Note: If test cases have custom fields that need to be included in test runs, the Helix ALM administrator
or another high-level user must map the test case fields to the corresponding test run custom fields.
Choose Tools > Administration > Item Mapping Rules and select Generate Test Runs from Test
Cases as the Type.
Test case steps can be displayed in different views in test runs:
n

Grid view displays steps and expected results in rows and columns. This is the most basic view of the
test case steps. Use this view if you only need to perform steps, mark them as complete, and add problem
statements to indicate where issues occur during the test.

n

Detail grid view displays an overview pane that provides a read-only view of the entire test run and a
detail pane that guides you step-by-step through the test run. You can enter results (Pass, Fail,
Undetermined) for each step in this view. Use this view if you are testing in a regulated environment or
need to meet compliance requirements. In this view, you can pass or fail each step and include detailed
information for each step, such as the actual results and file attachments to provide evidence that the test
was performed.
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What information do test runs include?

n
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Text view displays steps as text. Markup codes indicate the type of text on each line. Use this view if you
are comfortable using markup code and want to quickly add test run results or if you need to paste results
from another source, such as a text file.

When should I generate test runs?

You can select the steps view in the Display test runs generated for this test case in field on the test case
Steps tab. You may not be able to select a view depending on the project options.

When should I generate test runs?
Test runs are typically generated when test cases are complete and the product is ready for testing. You may
want to generate test runs at the beginning of each testing phase so you can more easily track the test cases
that test runs have been generated for. This can also help you evaluate how many test runs still need to be
performed so you can determine the status of the testing cycle. For example, generate test cases at the
beginning of the Alpha testing phase, at the beginning of the Beta testing phase, and for each Beta build.
Depending on your organization’s workflow, you may only be able to generate test runs from test cases in a
specific state. For example, the default test cases workflow only allows you to generate test runs for test
cases in the Ready state.
To generate test runs, select a test case on the Test Cases list window and choose Activities > Generate
Test Runs.
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How do I enable test run compliance options?

How do I enable test run compliance options?
If you need to ensure your organization's testing practices are followed or must comply with specific
standards and regulations, the Helix ALM administrator or another high-level user may want to enable
enhanced compliance for test runs.
If enhanced compliance is enabled, all test runs are generated in detail grid view. Additional options are
available to enforce the following rules before test runs are saved:
n

All steps must have a step result before the test run can be passed or failed

n

All steps must pass before the test run can be passed

n

The test run cannot be passed if any steps fail

n

A problem statement is required for each step that fails

n

The actual results field is required for steps that have a step result of pass or fail

n

An issue must be linked to the test run if the test run fails

n

The step result field cannot be set to undetermined

To enable enhanced compliance options, choose Tools > Administration > Project Options and then
select Test Runs from the Compliance category.
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How can I organize test cases and test runs?

Keep in mind that the test runs workflow can also be customized to define the path a test run takes from start
to close.

How can I organize test cases and test runs?
You may already use test suites. Test suites are collections or series of related tests. In Helix ALM, you can
use folders for test suites. For example, you may want to group tests based on testing phase, purpose,
functional area, or other criteria. Using test suites helps you more easily reuse test cases, keep tests
organized, and run tests in the correct order if needed.
Helix ALM has two types of folders used exclusively for test case management:
n

Test case suites, which can only contain test cases or other test case suite folders.

n

Test run suites, which can only contain test runs or other test run suite folders.

The following example shows how test case and test run suite folders can be used to group related tests. See
the Helix ALM help for best practices for setting up test suite folders.
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How do I use a test run to perform a test?

Test runs can be added to test run sets when they are generated. Test run sets are similar to folders, but the
test run set is displayed in the Edit Test Run and View Test Run dialog boxes. For example, you may want to
create a test run set for each milestone in the testing cycle. This can help you when it is time to generate
reports to evaluate testing progress.
Note: The Helix ALM administrator or another high-level user generally configures folders, custom fields,
and test run sets.

How do I use a test run to perform a test?
When a test run is assigned to you, open it and review information on the following tabs before you perform the
test.
n

The Detail tab includes general information about the test, including any setup instructions.

n

The Steps tab includes the steps, expected results, and files you need to perform the test. You enter
actual results observed during the test on this tab.

n

The Variants tab includes the information about the variable elements of the application that need to be
tested. This information can help you make sure you are using the correct environment to perform the test.

n

The Files tab may include files or scripts you need to perform the test.

Perform each step as described on the Steps tab. If the actual result is different from the expected result, add
problem statements and attachments, such as screenshots, to explain the issues. You may also be able to
pass or fail each step.
Next, indicate if the test passed, failed, or if the results were unclear. Choose Activities > Enter Results and
select a resulting state to indicate the test result. The test run moves to this status when you save it.

How do I print test runs to use when performing a test?
You can print detail reports to use when you perform a test. To create a test run detail report, choose Create >
Report. Select Detail and click OK. Select Test Runs from the Report contains field.
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What should I do if a test fails?

Test run detail reports include all information about a test run. You can use this report to review the workflow
for a test run to understand where it stands in your testing process and the next steps. To print the report, click
the Print button in the Edit Test Case dialog box and make sure the TestRunDetailReport.xslt stylesheet is
selected.
Test run checklist reports include the test run details in a format you can use for handwritten information. You
can use this report to perform a test and capture the results if Helix ALM is not installed on the test computer
or you want to write the results before entering them in Helix ALM. To create this report, make sure the
TestRunStepsDetailReport.xslt stylesheet is selected. The following example shows a test run checklist
report.

What should I do if a test fails?
If your organization uses an issue management tool, add an issue for the failed test to push the failure into
your workflow so it can be fixed and retested.
If your organization uses Helix ALM issue management, you can add an issue from the failed test run. The
test run information is copied to the issue so other users can review the steps to reproduce the problem when
fixing the issue or verifying the fix.
To create an issue from a test run, click Create Issue in the Edit Test Run dialog box.
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How do I determine how much testing remains?

After the issue is fixed, you can regenerate the test run so the test can be performed again.
Note: The Helix ALM administrator or another high-level user can change the information copied to issues
from the test runs they are created from. Choose Tools > Administration > Item Mapping Rules and
select Create Issue from Test Run as the Type.

How do I determine how much testing remains?
You can create a distribution report based on test run sets to view a snapshot of test runs at a specific point in
the testing cycle. For example, as you approach the end of the Alpha testing phase, generate a distribution
report based on the Alpha test run set to see how much testing remains. To create a test run distribution
report, choose Create > Report. Select Distribution and click OK. Select Test Runs from the Report
contains field.
Test run status by test run set reports includes the status of test runs in each test run set. This report can help
you determine how many test runs are waiting, in progress, on hold, or completed for each test run set. To
create this report, select the Status by option and then select Test Run Set from the corresponding list. The
following example shows the test run status report.
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How can I use Helix ALM with my automated testing tool?

Test run result status by test run set reports include the test run results for each test run set. These reports
can help you determine how many test runs in each test run set are passed, failed, or undetermined. To create
this report, select Run result status by and then select Test Run Set from the corresponding list.

How can I use Helix ALM with my automated testing tool?
Helix ALM integrates with QA Wizard Pro and other automation tools, making it easy to manage your manual
and automated tests and test results from one application.
To accurately automate a manual test, you simply follow the steps from the corresponding test case while
recording the automated test. To create automated tests from Helix ALM, click the Steps tab in the open test
case and click Create Script.
After creating automated tests, you can automatically attach result reports to test runs instead of manually
entering results. You can also configure Helix ALM to automatically move test runs through the workflow
based on automated test results.
If you use QA Wizard Pro, you can also record steps for new test cases instead of manually entering them,
which saves time when creating regression test cases. See the QA Wizard Pro help for information about
recording test case steps and automated tests.
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